package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\b(?:Test1 \(VI|Test2 \(VI\))\b`)
var str = `Test2 (VI)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}