using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^5[012][0-9]*$";
string input = @"50
51
52
13
5147sdfa
502121
526
571";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}