package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)IP-Group=\{(?<ipgroup1>[^}]+)\}(?:\s+\{(?<ipgroup2>[^}]+)\})?(?:\s+\{(?<ipgroup3>[^}]+)\})?`)
var str = `IP-Group={xxxx} {yyyy} {zzz}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}