re = /IP-Group=\{(?<ipgroup1>[^}]+)\}(?:\s+\{(?<ipgroup2>[^}]+)\})?(?:\s+\{(?<ipgroup3>[^}]+)\})?/m
str = 'IP-Group={xxxx} {yyyy} {zzz}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end