using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-zA-Z0-9_\.-]+@[a-zA-Z]+\.[A-Za-z]+(.[a-zA-Z]+)?";
string input = @"foo-bar.baz@example.com
alguien@algunlugar.es
tc.45mariasol@gmail.com.es
marias@sol@hola.gcom.ar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}