const regex = /[a-zA-Z0-9_\.-]+@[a-zA-Z]+\.[A-Za-z]+(.[a-zA-Z]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z0-9_\\.-]+@[a-zA-Z]+\\.[A-Za-z]+(.[a-zA-Z]+)?', 'gm')
const str = `foo-bar.baz@example.com
alguien@algunlugar.es
tc.45mariasol@gmail.com.es
marias@sol@hola.gcom.ar
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}