using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"value=""([^""]+)"".+?ip_h:\s*'\1'";
string input = @"1. name=""ip_h"" value=""658c9f771e0ceb7сс1"" />
2. ip_h: '658c9f771e0ceb7сс1',";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}