$re = '/value="([^"]+)".+?ip_h:\s*\'\1\'/ms';
$str = '1. name="ip_h" value="658c9f771e0ceb7сс1" />
2. ip_h: \'658c9f771e0ceb7сс1\',';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);