using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\d?((\d)(?!\2)\d)\1{3})\d{9}$";
string input = @"561616161
121212123
411111111
111111114
111111111
299887766
887756564
123412345
123123123
934343434
934343435
934345634";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}