const regex = /^(?=\d?((\d)(?!\2)\d)\1{3})\d{9}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\d?((\\d)(?!\\2)\\d)\\1{3})\\d{9}$', 'gm')
const str = `561616161
121212123
411111111
111111114
111111111
299887766
887756564
123412345
123123123
934343434
934343435
934345634`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}