using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@\w+(?![^@]*\bkeyword\b)";
string input = @"@something
something
something
keyword
something
something
@something
something
something
something
something
@something
something
something
keyword
something
something";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}