$re = '/@\w+(?![^@]*\bkeyword\b)/m';
$str = '@something
something
something
keyword
something
something
@something
something
something
something
something
@something
something
something
keyword
something
something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);