$re = '/(?i)(?!\bprofound\b)(lost|found)/m';
$str = 'It was lost long ago
I found it here
my feelings were profound';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);