re = /(?i)(?!\bprofound\b)(lost|found)/m
str = 'It was lost long ago
I found it here
my feelings were profound'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end