package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\$\d+(?:\.\d+)?)[\s\S]*`)
var str = `5 Easy Payments $94.00 $99.00 (176)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}