package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[^\s=]++=\w+`)
var str = `aaaa bbbb cccc=v1
aaaa bbbb cccc=v1
aaaa bbbb cccc=v1
aaaa bbbb cccc=v1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}