re = /\b[^\s=]++=\w+/m
str = 'aaaa bbbb cccc=v1
aaaa bbbb cccc=v1
aaaa bbbb cccc=v1
aaaa bbbb cccc=v1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end