using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\w+ )*+\K[^\s=]++=\w+";
string input = @"aaaa bbbb cccc=v1
aaaa bbbb cccc=v1
aaaa bbbb cccc=v1
aaaa bbbb cccc=v1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}