package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[\w\W][^\s!?.]+)$`)
var str = `une-%C3%A9cole-234_we`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}