$re = '/^(?:[\w\W][^\s!?.]+)$/m';
$str = 'une-%C3%A9cole-234_we';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);