using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(c1|c2)(.*?)\1";
string input = @"c1 1 c1
c2 2 c2
c1 3 c1
c2 4 c2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}