$re = '/(c1|c2)(.*?)\1/m';
$str = 'c1 1 c1
c2 2 c2
c1 3 c1
c2 4 c2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);