import re
regex = re.compile(r"^SUMME \/ W;\d{1,3};;\d{1,3};\d{1,3};\d{1,3};\K\d{1,3}", flags=re.MULTILINE)
test_str = ("02.03.;38;;;3;1;42;\n"
"03.03.;36;;;3;;39;\n"
"04.03.;51;;14;9;1;75;\n"
"05.03.;70;;9;9;;88;\n"
"06.03.;26;;;2;;28;\n"
"SUMME / W;221;;23;26;2;272;\n"
"09.03.;35;;10;6;1;52;\n"
"10.03.;50;;3;4;;57;\n"
"11.03.;48;;4;8;;60;\n"
"12.03.;35;;;4;1;40;\n"
"13.03.;15;;;3;;18;\n"
"SUMME / W;183;;17;25;2;227;\n"
"16.03.;23;;7;2;1;33;\n"
"17.03.;36;;1;3;;40;\n"
"18.03.;36;;;8;;44;\n"
"19.03.;34;;;2;;36;\n"
"20.+21.03.;22;;4;3;;29;\n"
"SUMME / W;151;;12;18;1;182;\n"
"23.03.;38;;4;4;1;47;\n"
"24.03.;26;;4;5;;35;\n"
"25.03.;24;;7;5;;36;\n"
"26.03.;22;;;3;;25;\n"
"27.+28.03.;4;;;2;;6;\n"
"SUMME / W;114;;15;19;1;149;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")