package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}$`)
var str = `000
111
123
321
3211
32
32a
a32
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}