const regex = /^(?:(?:1?\d?\d|2[0-4]\d|25[0-5])\.?\b){4}$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:1?\\d?\\d|2[0-4]\\d|25[0-5])\\.?\\b){4}$', 'mg')
const str = `Validate an IPv4 address. The addresses are four numbered separated by three dots, and can only have a maximum value of 255 in either octet. Start by trying to validate 172.16.254.1.
172.16.254.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}