re = /^(?:(?:1?\d?\d|2[0-4]\d|25[0-5])\.?\b){4}$/m
str = 'Validate an IPv4 address. The addresses are four numbered separated by three dots, and can only have a maximum value of 255 in either octet. Start by trying to validate 172.16.254.1.
172.16.254.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end