#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)^SCHEDULE(?:.(?!^END$))*?#\/[^\r\n]*E\r?\n(?:(?!^$).)*?[ \t]*NOP$.*?^END$"
Local $sString = "" & @CRLF & _
"SCHEDULE MASTERAGENTS#KA0HM00_LEASE " & @CRLF & _
"DESCRIPTION "Added by composer."" & @CRLF & _
":" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM010_LEASE_AFT" & @CRLF & _
" FOLLOWS KA0HM003_LEASE" & @CRLF & _
" FOLLOWS KA0HM007_LEASE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM006_LEASE" & @CRLF & _
" FOLLOWS KA0HM004_LEASA" & @CRLF & _
" NOP" & @CRLF & _
"" & @CRLF & _
"MASTERAGENTS#/KA0H/KA0HM00_LEASE/KA0HM00SLEASE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM003_LEASE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM002_LEASE" & @CRLF & _
" FOLLOWS KA0HM001_LEASE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM001_LEASE" & @CRLF & _
" FOLLOWS KA0HM00S_LEASE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"MASTERAGENTS#/KA0H/KA0HM00_LEASE/KA0HM00E_LEASE" & @CRLF & _
" FOLLOWS KA0HM010_LEASE_AFT" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM004_LEASE" & @CRLF & _
" FOLLOWS KA0HM002_LEASE" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM009_LEASE" & @CRLF & _
" FOLLOWS KA0HM004_LEASE" & @CRLF & _
"" & @CRLF & _
"END" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")