import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)^SCHEDULE(?:.(?!^END$))*?#\\/[^\\r\\n]*E\\r?\\n(?:(?!^$).)*?[ \\t]*NOP$.*?^END$";
final String string = "\n"
+ "SCHEDULE MASTERAGENTS#KA0HM00_LEASE \n"
+ "DESCRIPTION \"Added by composer.\"\n"
+ ":\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM010_LEASE_AFT\n"
+ " FOLLOWS KA0HM003_LEASE\n"
+ " FOLLOWS KA0HM007_LEASE\n\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM006_LEASE\n"
+ " FOLLOWS KA0HM004_LEASA\n"
+ " NOP\n\n"
+ "MASTERAGENTS#/KA0H/KA0HM00_LEASE/KA0HM00SLEASE\n\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM003_LEASE\n\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM002_LEASE\n"
+ " FOLLOWS KA0HM001_LEASE\n\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM001_LEASE\n"
+ " FOLLOWS KA0HM00S_LEASE\n\n\n"
+ "MASTERAGENTS#/KA0H/KA0HM00_LEASE/KA0HM00E_LEASE\n"
+ " FOLLOWS KA0HM010_LEASE_AFT\n\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM004_LEASE\n"
+ " FOLLOWS KA0HM002_LEASE\n\n\n"
+ "CLA0HDST01#/KA0H/KA0HM00_LEASE/KA0HM009_LEASE\n"
+ " FOLLOWS KA0HM004_LEASE\n\n"
+ "END\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}