package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)submitted by .+ (.+) :`)
var str = `The following records request has been submitted by Bryan Trummer :`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}