$re = '/submitted by .+ (.+) :/m';
$str = 'The following records request has been submitted by Bryan Trummer :';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);