#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*?[^*\s]+\*?$"
Local $sString = "あLLOW" & @CRLF & _
"" & @CRLF & _
"*strあing*" & @CRLF & _
"*strうing" & @CRLF & _
"striいng*" & @CRLF & _
"strえing" & @CRLF & _
"" & @CRLF & _
"DえNY" & @CRLF & _
"" & @CRLF & _
"*str*ing*" & @CRLF & _
"*str*ing" & @CRLF & _
"str*ing*" & @CRLF & _
"str*ing" & @CRLF & _
"*string**"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")