re = /^\*?[^*\s]+\*?$/m
str = 'あLLOW
*strあing*
*strうing
striいng*
strえing
DえNY
*str*ing*
*str*ing
str*ing*
str*ing
*string**'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end