using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a\b[^>]+>.*?<\/a>\K|Example";
string input = @"<a class=""Example"" href=""http://www.example.com/"">Example</a>
<p>New **Example**</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}