$re = '/<a\b[^>]+>.*?<\/a>\K|Example/';
$str = '<a class="Example" href="http://www.example.com/">Example</a>
<p>New **Example**</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);