#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)task (.*?) ?\(type: (.*)\) \{"
Local $sString = "task distClean (type: Delete) {" & @CRLF & _
"task distClean(type: Delete) {" & @CRLF & _
"task adhoc {"
Local $sSubst = "def $1 = tasks.register('$1', $2) {"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)