$re = '/task (.*?) ?\(type: (.*)\) \{/m';
$str = 'task distClean (type: Delete) {
task distClean(type: Delete) {
task adhoc {';
$subst = "def $1 = tasks.register('$1', $2) {";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;