#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[A-Z][a-z]*$)(?i)(?!.*[aeiouy]{3}|.*[^aeiouy\n]{3})[a-z]+$"
Local $sString = "Aakemenkyu" & @CRLF & _
"Aaakemenkyu" & @CRLF & _
"Klepathass" & @CRLF & _
"Waknampite" & @CRLF & _
"Wwwaknampite" & @CRLF & _
"Flaetobsak" & @CRLF & _
"Oladkinqyt" & @CRLF & _
"Mmalinnetj" & @CRLF & _
"MmalinnetjJ" & @CRLF & _
"Ijythlzuoe" & @CRLF & _
"Tervkpxyib" & @CRLF & _
"Ifuemkoeui" & @CRLF & _
"Mqjtobojex" & @CRLF & _
"Ephyrjiuau"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")