import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[A-Z][a-z]*$)(?i)(?!.*[aeiouy]{3}|.*[^aeiouy\\n]{3})[a-z]+$";
final String string = "Aakemenkyu\n"
+ "Aaakemenkyu\n"
+ "Klepathass\n"
+ "Waknampite\n"
+ "Wwwaknampite\n"
+ "Flaetobsak\n"
+ "Oladkinqyt\n"
+ "Mmalinnetj\n"
+ "MmalinnetjJ\n"
+ "Ijythlzuoe\n"
+ "Tervkpxyib\n"
+ "Ifuemkoeui\n"
+ "Mqjtobojex\n"
+ "Ephyrjiuau";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}