const regex = new RegExp('(?<=/)(\\d+)(?=-)', '')
const str = `http://www.example.com/cat1/something/subcat/543210-1abce-dsef100-199-test.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}