$re = '~(?<=/)(\d+)(?=-)~';
$str = 'http://www.example.com/cat1/something/subcat/543210-1abce-dsef100-199-test.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);