package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_][\w]*`)
var str = `let Woot = 40 + 5;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}