$re = '/[a-zA-Z_][\w]*/m';
$str = 'let Woot = 40 + 5;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);