$re = '/LDCAccountNumber\":\"(?<LDCAccountNumber>\d+)\",\"BudgetBilling/';
$str = '"LDCAccountNumber":"4346780895","BudgetBilling":"N","TaxExempt":"N",{"field":"BudgetBilling",';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);