re = /LDCAccountNumber\":\"(?<LDCAccountNumber>\d+)\",\"BudgetBilling/
str = '"LDCAccountNumber":"4346780895","BudgetBilling":"N","TaxExempt":"N",{"field":"BudgetBilling",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end