#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)\d\d\+ boys only|wow only \d\d\+|only \d\d\+ (?:boys|allowed)|\d\d\+ only boys|boys only \d\d\+|(?:Onlyfans|teen|NSFW|nude).* l[3e][4a]ks*?|(?:underage|T[3e]{2}n|🔞|18\+) (?:nudes|content ?(?:discord|l[3e][4a]ks*?|here)*?|p[0o]*?rn|pr[0o]*?n)|l[3e]{2}[4a\*]*?k (?:Onlyfans|teen|NSFW|nude)"
Local $sString = "==========AUTOMOD INSTRUCTIONS===========" & @CRLF & _
"The above regex is used to mute users. " & @CRLF & _
"" & @CRLF & _
"The following regex is used to ban users (each newline is a different "mesage matches regex" trigger on a single rule (because of character limits) " & @CRLF & _
"" & @CRLF & _
"gg/(sextiktok|freecheats|goldtiktok|tiktoksex|eegirls|esexx|desexys|kissmee|bellanudes|essex|trashnudes|tiktok18|freetiktok|bestnudes|esexhentai|tiktokhomes|welcomensfw|dcleaks|onlynudes|websluts|fullnudes|leeknudeteen|xxnude|tiktoksnfw|xxxpussy)" & @CRLF & _
"" & @CRLF & _
"gg/(nudeteen|leaks4you|xxxhots|pent|sexshare|tiktokteens|ofporn|teenscp|xxxvids|wifey|nudeporn|teengirl|cpteens|sexyhot|sexyteen)" & @CRLF & _
"" & @CRLF & _
"gg/(Vm2RwraURb|WS6k2Yxe|kwJk8Ntz|faqADJpbkR|MscE4Gp2|HcqGy9c7yE|KKmUfYU92x|rryS5NyRhq|7DRYnTwFCS|G56FvssV)" & @CRLF & _
"" & @CRLF & _
"(?i)\[steamcommunity\.com\/gift\/\d+\]\(<?https:\/\/.+>?\)" & @CRLF & _
"" & @CRLF & _
"==========ACTUAL TEST STRINGS===========" & @CRLF & _
"Hot Teen & Nsfw Leaks :underage: :peach: https://discord.gg/7DRYnTwFCS @everyone" & @CRLF & _
"" & @CRLF & _
"Onlyfans leaks + Teen content here 🍑 🍒" & @CRLF & _
"" & @CRLF & _
"@everyone Free Onlyfans and Leaks here: discord.gg/dcleaks" & @CRLF & _
"https://discord.gg/MscE4Gp2 FREE NSFW + 40€ GIVEAWAY + Leaks + PORN" & @CRLF & _
"" & @CRLF & _
"🔞 Free 18+ Content + Free Teen Leaks @here @everyone:" & @CRLF & _
"https://discord.gg/leeknudeteen Best server for leek nude +18" & @CRLF & _
"" & @CRLF & _
"Free 18+ Content: :peach: @here @everyone" & @CRLF & _
"" & @CRLF & _
"🔞 content" & @CRLF & _
"" & @CRLF & _
"Teen Content & OnlyFans Leaks 🍑🔞" & @CRLF & _
"" & @CRLF & _
"Onlyfans leaks + Teen content here :heart: : https://discord.gg/sexshare @everyone " & @CRLF & _
"" & @CRLF & _
"BEST OnlyFans LEAKS & Teen Content 🍑 🔞" & @CRLF & _
"" & @CRLF & _
"Onlyfans leaks + Teen content here :heart: : https://discord.gg/teenscp @everyone" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")