import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\d\\d\\+ boys only|wow only \\d\\d\\+|only \\d\\d\\+ (?:boys|allowed)|\\d\\d\\+ only boys|boys only \\d\\d\\+|(?:Onlyfans|teen|NSFW|nude).* l[3e][4a]ks*?|(?:underage|T[3e]{2}n|🔞|18\\+) (?:nudes|content ?(?:discord|l[3e][4a]ks*?|here)*?|p[0o]*?rn|pr[0o]*?n)|l[3e]{2}[4a\\*]*?k (?:Onlyfans|teen|NSFW|nude)";
final String string = "==========AUTOMOD INSTRUCTIONS===========\n"
+ "The above regex is used to mute users. \n\n"
+ "The following regex is used to ban users (each newline is a different \"mesage matches regex\" trigger on a single rule (because of character limits) \n\n"
+ "gg/(sextiktok|freecheats|goldtiktok|tiktoksex|eegirls|esexx|desexys|kissmee|bellanudes|essex|trashnudes|tiktok18|freetiktok|bestnudes|esexhentai|tiktokhomes|welcomensfw|dcleaks|onlynudes|websluts|fullnudes|leeknudeteen|xxnude|tiktoksnfw|xxxpussy)\n\n"
+ "gg/(nudeteen|leaks4you|xxxhots|pent|sexshare|tiktokteens|ofporn|teenscp|xxxvids|wifey|nudeporn|teengirl|cpteens|sexyhot|sexyteen)\n\n"
+ "gg/(Vm2RwraURb|WS6k2Yxe|kwJk8Ntz|faqADJpbkR|MscE4Gp2|HcqGy9c7yE|KKmUfYU92x|rryS5NyRhq|7DRYnTwFCS|G56FvssV)\n\n"
+ "(?i)\\[steamcommunity\\.com\\/gift\\/\\d+\\]\\(<?https:\\/\\/.+>?\\)\n\n"
+ "==========ACTUAL TEST STRINGS===========\n"
+ "Hot Teen & Nsfw Leaks :underage: :peach: https://discord.gg/7DRYnTwFCS @everyone\n\n"
+ "Onlyfans leaks + Teen content here 🍑 🍒\n\n"
+ "@everyone Free Onlyfans and Leaks here: discord.gg/dcleaks\n"
+ "https://discord.gg/MscE4Gp2 FREE NSFW + 40€ GIVEAWAY + Leaks + PORN\n\n"
+ "🔞 Free 18+ Content + Free Teen Leaks @here @everyone:\n"
+ "https://discord.gg/leeknudeteen Best server for leek nude +18\n\n"
+ "Free 18+ Content: :peach: @here @everyone\n\n"
+ "🔞 content\n\n"
+ "Teen Content & OnlyFans Leaks 🍑🔞\n\n"
+ "Onlyfans leaks + Teen content here :heart: : https://discord.gg/sexshare @everyone \n\n"
+ "BEST OnlyFans LEAKS & Teen Content 🍑 🔞\n\n"
+ "Onlyfans leaks + Teen content here :heart: : https://discord.gg/teenscp @everyone\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}