const regex = /.*(?=\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*(?=\\\/)', 'gm')
const str = `https://www.businessinsider.de/gruenderszene/plus-angebot/?tpcc=onsite_gs_header_nav&verification_code=DOVCGF75J8LSID&_ptid=%7Bkpdx%7DAAAA0Urc6Ir0lQoKN245U3NTVndwdRIQbDVoMzl2NW11ZXgxamJhZRoMRVhGU0NHMjRJVElTIiUxODA1YXZvMGNrLTAwMDAzMGZlaHRldTM0OWl0MGpvYXAzczRvKhdzaG93T2ZmZXJCTEFYWVFVTEdNTUMxODABOgxPVEo4RDNFUUQzTzRKIm9uc2l0ZV9nc19oZWFkZXJfbmF2OjE2NTc1NjQ3ODE4MTZSEnYtlgDwFnFubndiNG1rWgw5My4xOTUuMTIuOTliA21pc2ju_7aWBnAHeAw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}