import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\|.*)$";
final String string = "[17-12-14 19:31:55:251 GMT] \n"
+ "[17-12-14 19:31:55:252 GMT] ID\n"
+ "[17-12-14 19:31:55:253 GMT] 11111||q467jeX\n"
+ "[17-12-14 19:31:55:254 GMT] undefined\n"
+ "[17-12-14 19:31:55:255 GMT] \n"
+ "[17-12-14 19:31:55:256 GMT] ID\n"
+ "[17-12-14 19:31:55:257 GMT] undefined\n"
+ "[17-12-14 19:31:55:258 GMT] 22222||K6OmenP\n"
+ "[17-12-14 19:31:55:259 GMT] ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}