# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\|.*)$"
test_str = ("[17-12-14 19:31:55:251 GMT] \n"
"[17-12-14 19:31:55:252 GMT] ID\n"
"[17-12-14 19:31:55:253 GMT] 11111||q467jeX\n"
"[17-12-14 19:31:55:254 GMT] undefined\n"
"[17-12-14 19:31:55:255 GMT] \n"
"[17-12-14 19:31:55:256 GMT] ID\n"
"[17-12-14 19:31:55:257 GMT] undefined\n"
"[17-12-14 19:31:55:258 GMT] 22222||K6OmenP\n"
"[17-12-14 19:31:55:259 GMT] ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.