re = /^UC(?:T|F[LCA]?|PA?)\d{3}$/mi
str = 'UCF123
UCP123
UCT123
UCFL123
UCFC123
UCFA123
UCPA123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end